Slow Dashboard Performance

Incident Report for PeopleMetrics

Monitoring

Dashboard performance has returned to normal levels.

No further impact is expected, and we will continue monitoring.
Posted Feb 09, 2026 - 14:58 EST

Investigating

We are currently investigating reports of slow dashboard loading times. This appears to be related to an AWS service issue.

Our team is actively working to identify the root cause and will provide updates as more information becomes available.
Posted Feb 09, 2026 - 12:53 EST
This incident affects: PeopleMetrics CEM.